Reason: Due to the latest changes in the GenRocket runtime, an execution of the new scenario requires the new GenRocket Engine jar (gr-engine-3.5.21.2.jar) so, if the new Scenario gets executed using the older GenRocket Engine jar then, this exception might occur.



Solution:

Kindly download the updated GenRocket runtime engine jar by executing the GenRocket runtime update command on the CMD or Terminal Window.


Command:

genrocket -a


After updating the GenRocket runtime engine jar, please run the same scenario again.


Notes:

  1. The runtime Engine jar version should be equal or higher to the current version 3.5.21.2.
  2. On Windows, after downloading the latest GenRocket Engine jar, kindly run GenRocket Cleanup command on the CMD or Terminal Window to remove the obsolete runtime jars existing in the %GEN_ROCKET_HOME%\lib directory.

GenRocket Cleanup Command: genrocketcl