Description

This article provides information about the user interface components of the G-Feature File Management Dashboard


In This Article


How to Access the G-Feature File Management Dashboard

Complete the following steps to access the G-Feature File Management Dashboard 


Step 1: Select a Project within the Project Dashboard.


Step 2: Expand the Self Serve Options Menu for the appropriate Project Version.


Step 3: Select G-Feature File within the drop-down menu.



The G-Feature File Management Dashboard will appear as shown below:




G-Feature File Management Dashboard Panes

The G-Feature File Management Dashboard contains four panes: 

  • G-Feature File Suites Pane
  • Feature Files Pane
  • Feature File Editor Pane
  • Feature File Preview Pane


G-Feature File Suites Pane

G-feature File Suites Pane contains one or more Feature Files for a Project Version of a given Project. At least one suite must be present within the G-Feature File Management Dashboard to import or add a Feature File. 



G-Feature File Suites Pane Buttons and Icons

The G-Feature File Suites Pane contains the following buttons and icons:


  Button/Icon

Description

Add a new G-Feature File Suite to the selected Project Version. 
Edit the Name and Description of a G-Feature File Suite. 
Create a copy of a G-Feature File Suite. 
Download an entire G-Feature File Suite to a user's local computer.
Lock the G-Feature File Suite. 
Unlock the G-Feature File Suite. 
Delete a G-Feature File Suite. 



Feature Files Pane

Feature Files within a suite can be viewed and selected at the bottom of the G-Feature File Management Dashboard. The selected Feature File will be highlighted in blue. 



Feature Files Pane Buttons and Icons

The Feature Files Pane contains the following buttons and icons: 


Button/Icon

Description

Add a new Feature to a selected G-Feature File Suite.
Import a Feature File into a selected G-Feature File Suite. 
Download an individual Feature File to the user's local computer. 
Edit a Feature File Name and Description. 
Create a copy of a Feature File within a G-Feature File Suite. 
Delete a Feature from a G-Feature File Suite.



Feature File Editor Pane

The Feature File Editor Pane is used to update and make changes to a selected Feature File. It contains several buttons for adding comments, keywords, steps, data tables, and G-Data Tables to a Feature File.   



Feature File Editor Pane

The Feature File Editor Pane contains the following buttons: 


Keyword Button

Description

Add a Scenario Outline keyword to the Feature File.
Add a Scenario Template keyword to the Feature File.
Add a Scenarios keyword to the Feature File.
Add an Examples keyword to the Feature File.
Add a Rule keyword to the Feature File.
Add a Background keyword to the Feature File. 
Add a Scenario keyword to the Feature File.
Add an Example keyword to the Feature File. 
Include Star Notation in the Feature File. This allows the star to be used instead of keywords. 
Add Comments to the Feature File.
Add Tags to the Feature File.
Add Doc Strings to the Feature File. 
Add Doc Strings to the Feature File. 
Add a Given step to the Feature File.
Add a When step to the Feature File. 
Add a Then step to the Feature File. 
Add an And step to the Feature File. 
Add a But step to the Feature File. 
Select a type of Data Table and manually add it to the Feature File.
Add a G-Data Table to the Feature File.



The Feature File Editor Pane contains the following icons:


Icon

Description

Edit the details of an item within the selected Feature File. 
Remove an item from the selected Feature File. 
Copy an existing item within the selected Feature File. 
Change the position of an item within the selected Feature File. 
Expand or collapse an item within the Feature File.


Feature File Preview Pane

Users can preview the Feature File in Gherkin or as a Step Definition within the Feature File Preview Pane. Click on a tab to make a selection.  



Icon

Description

Expand the Feature File Preview Pane.
Copy text to the clipboard.