Description

A Feature File can be manually added to a selected G-Feature File Suite. Once added, users can add Comments, Keywords, Steps, Document Strings, Data Tables, and G-Data Tables to the Feature File.  


In This Article


Step 1: Access the G-Feature File Management Dashboard

  • Select a Project within the Project Dashboard.



  • Expand the Self Serve Options Menu for the appropriate Project Version.

  • Select G-Feature File within the drop-down menu.


Step 2: Select a G-Feature File Suite 

  • Click on a G-Feature File Suite to select it within the dashboard.


Step 3: Add a New Feature File to the Suite

  • Click on the Add Feature button.



  • Enter a Name for the new G-Feature File.



  • (Optional) Users may also add a Story, Comments, and Tags to the new G-Feature File.



  • Click the Save button once finished.



The G-Feature File will be created and contain any entered Story information, Comments, and Tags.


Step 4: Add Keywords and Steps to the Feature File

After adding a Feature File, users will be able to add keywords (e.g., Scenario Outline, Rule, Background, Scenarios) and Steps (e.g., Given, When, Then), Data Tables, and G-Data Tables. 



Additional Information

The following articles can be used to learn more about modifying a Feature File: 


Topic
Description
How to add Keywords and Steps to Feature Files
Learn how to add Keywords and Steps to Feature Files.

How to add Data Tables to Feature Files

Learn how to add Data Tables to Feature Files manually.

How to add G-Data Tables to Feature Files

Learn how to add G-Data Tables to Feature Files.