Supported Java Versions

The GenRocket Runtime Engine supports the following Java Versions: 

  • 1.8 (except 1.8u20)
  • 1.9
  • 1.10
  • 1.11
  • 1.12
  • 1.13
  • 1.14
  • 1.15


Note: Versions 1.16+ have not been tested with GenRocket Runtime.


Why is 1.8u20 not supported?

Due to multiple verifier bugs, our Groovy version is not compatible with JDK 1.8u20.


GenRocket Runtime Installation Overview

Please see GenRocket Runtime Installation Requirements for more installation information.